Excel 2010 da iki listede arananları eşleme, Excel formüller

         Elimizde Excel 2013, 2010 veya 2007 ye ait iki liste olsun  ve bu iki listede ortak iki eleman olsun biz diğer listedeki elemanın karşısına ortak olanı yazmak istiyoruz, excel 2010 fonksiyonlar

örn:


excel liste
LİSTE 1

elimizde bulunan alttaki liste 2 gibi ikinci bir listede hangi meslek grubunun ne kadar maaş aldığını yazan bir tablo olsun ve biz yandaki listenin LİSTE 1 in D sutunna maaş bölümü açarak liste 2 deki maaşların  karşılığı olan değerleri otamatik bir şekilde karşısına yazmasını istiyoruz.





LİSTE 2


Bunun için LİSTE 1 deki D2 Hücresine Düşeyara fonksiyonun yazarak eşleme yapmamız gerekir

=DÜŞEYARA(aranandeğer;tablodizisi;sutunindisi;eşleme);
şeklinde olmalıdır burada parantezler içinde  yazan

aranandeğer= Liste 1 ve Liste 2 de ortak olup karşılığı gelecek değer

tablodizisi = Liste 2 tüm tablo (A1 den B3 ) kadar olan
sutunindisi = Liste 1 e karşılık gelecek olan değerin liste 2 deki sırası 
a sutunu = 1 , b sutun = 2 gibi devam ediyor

eşleme = doğru yada yanlış seçeneği vardır yanlış seçilir ise birebir karşılık var ise değer döner doğruda ise birebirden ziyade en yakın değer var ise değer döner



TAM FORMÜL
=DÜŞEYARA(C2;Sayfa2!$A$1:$B$2;2;YANLIŞ)

D2 hücresine yazdığımız formülde C2 aranan değer öğretmenin maaşı olduğu alt hücreyi alta çektiğimizde bir alta kinin aranan değer olacağı 
Sayfa2!$A$1:$b$2 yazısı karşılık gelecek değerin sayfa 2 de bulunan seçili hücreler olduğu ve bunları $ işareti ile dondurarak hücreyi alt tarafa çektiğimizde seçili dizinin dışına çıkmasını engelledik
2 liste_2 re bulunan 2.sutun olduğu
ve tam eşleşenleri getirdik.
EXCEL listesi
sonuç liste
sonuç olarak listemizdeki maaş kısmını liste 2 deki mesleklerin karşısındaki maaşlara göre yaptık bu liste çok uzun bir liste olduğu zaman işimizi çok azaltmaktadır.

uyarı: arama karşılık larımızın bulunduğu Liste2 deki dizide aranan değer her zaman dizini baş sutunun da olması gerekir yani doktor mesleğinin karşılığını aradığımız için liste2 seçili dizi mesleklerinin bulunduğu sutundan başlamalıdır.

Yorum Gönderme